import re
regex = re.compile(r"\s*<div\s[^\"]*\"feature-bullets\"\s[\s\S]*(<ul[\s\S]*<\/ul>)", flags=re.MULTILINE)
test_str = ("<div id=\"feature-bullets\" class=\"a-section a-spacing-medium a-spacing-top-small\">\n\n\n\n\n\n\n\n\n"
" \n"
" \n"
" <ul class=\"a-unordered-list a-vertical a-spacing-none\">\n"
" \n"
" \n"
" <li><span class=\"a-list-item\"> \n"
" 100% Leather\n"
" \n"
" </span></li>\n"
" \n"
" <li><span class=\"a-list-item\"> \n"
" Imported\n"
" \n"
" </span></li>\n"
" \n"
" <li><span class=\"a-list-item\"> \n"
" Rubber sole\n"
" \n"
" </span></li>\n"
" \n"
" <li><span class=\"a-list-item\"> \n"
" Removable insole\n"
" \n"
" </span></li>\n"
" \n"
" </ul>\n"
" \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")