package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)`)
var str = `AAA BBB`
var substitution = "ZZZ - $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}