use strict;
my $str = 'AAA BBB';
my $regex = qr/(.*)/mp;
my $subst = 'ZZZ - $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";