package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)(.*?)\n+http://[^\n]*`)
var str = `Switch To Webmail Forward As Attachment
Subject: Happy Halloween! Save 20% off Your Customer Pick Order of $35+ & Get Free Shipping
From: "Steve Clayton, Inc." <questions@steveclayton.com>;
Date: CSUS : 2019-10-21 13:58:45 CSUK : 2019-10-21 21:58:45 CSAU : 2019-10-22 07:58:45 CSCA : 2019-10-21 16:58:45
To: alondra.lord@soarinfotech.com;
Greetings!
http://r20.rs6.net/tn.jsp?f=0014SGOrR3ASe9IyglfygZLXfHhrRAmkPn-73YbC2ynwMJ7PkFvp390uIy0yJCAN-mY1b-EkfryOvw5p9xfNsi4kjE2XQIXO3TMsMcUAVBvR12dZBb_uXVkIhiHjo-OwkYriobWoXY34X5wKNqE0g89LpSq1mz4yPT-0QUl6--2Sx_1zzmq_y2DxA==&c=FxWRjueN1esWXtTd5CiUManoqQSCzYeeNCYetAu6uISMrHXQi5jT_A==&ch=bfhpEqDHS21OhVfblebShZJCqsmks2YfZgG5E4G9rML4gixyTZXiQQ==
Steve Clayton, Inc., 201 Rogue River Parkway, Talent, OR 97540
http://ui.constantcontact.com/sa/fwtf.jsp?llr=oimxtpcab&m=1102183117070&ea=chrystal%40steveclayton.com&a=1133410274742
Forward email | https://visitor.constantcontact.com/do?p=oo&m=001qFmiWSczCnpJ0RpvJUB4sw%3D%3D&ch=9adda1e0-441c-11e9-ad0b-d4ae5292c4dd&ca=1c3a31d6-0436-4a39-b723-ecf6b602376e
Update Profile | http://www.constantcontact.com/legal/service-provider?cc=about-service-provider
About our service provider
Sent by mailto:questions@steveclayton.com
questions@steveclayton.com
"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}