# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*?)\n+http://[^\n]*"
test_str = ("Switch To Webmail Forward As Attachment \n\n"
"Subject: Happy Halloween! Save 20% off Your Customer Pick Order of $35+ & Get Free Shipping\n"
"From: \"Steve Clayton, Inc.\" <questions@steveclayton.com>;\n"
"Date: CSUS : 2019-10-21 13:58:45 CSUK : 2019-10-21 21:58:45 CSAU : 2019-10-22 07:58:45 CSCA : 2019-10-21 16:58:45 \n"
"To: alondra.lord@soarinfotech.com;\n\n"
" Greetings!\n\n"
"http://r20.rs6.net/tn.jsp?f=0014SGOrR3ASe9IyglfygZLXfHhrRAmkPn-73YbC2ynwMJ7PkFvp390uIy0yJCAN-mY1b-EkfryOvw5p9xfNsi4kjE2XQIXO3TMsMcUAVBvR12dZBb_uXVkIhiHjo-OwkYriobWoXY34X5wKNqE0g89LpSq1mz4yPT-0QUl6--2Sx_1zzmq_y2DxA==&c=FxWRjueN1esWXtTd5CiUManoqQSCzYeeNCYetAu6uISMrHXQi5jT_A==&ch=bfhpEqDHS21OhVfblebShZJCqsmks2YfZgG5E4G9rML4gixyTZXiQQ==\n\n"
" \n"
"Steve Clayton, Inc., 201 Rogue River Parkway, Talent, OR 97540\n\n\n"
"http://ui.constantcontact.com/sa/fwtf.jsp?llr=oimxtpcab&m=1102183117070&ea=chrystal%40steveclayton.com&a=1133410274742\n"
"Forward email | https://visitor.constantcontact.com/do?p=oo&m=001qFmiWSczCnpJ0RpvJUB4sw%3D%3D&ch=9adda1e0-441c-11e9-ad0b-d4ae5292c4dd&ca=1c3a31d6-0436-4a39-b723-ecf6b602376e\n"
"Update Profile | http://www.constantcontact.com/legal/service-provider?cc=about-service-provider\n"
"About our service provider\n"
"Sent by mailto:questions@steveclayton.com\n"
"questions@steveclayton.com\n"
" \n\n\n"
"\"")
matches = re.finditer(regex, test_str, re.DOTALL | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.