using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Insurance.*\[(\d+)\]";
string input = @"<td class=""th-clr-cel th-clr-td th-clr-pad th-clr-cel-dis"" style=""width:226px; text-align:left; "">
<span class=""th-tx th-tx-value th-tx-nowrap"" style=""width:100%; "" title=""Social Insurance Number (SIN)"" id=""C29_W120_V121_builidnumber_table[5].type_text"" f2=""C;40"">
Social Insurance Number (SIN)
</span>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}