# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Insurance.*\[(\d+)\]"
test_str = ("<td class=\"th-clr-cel th-clr-td th-clr-pad th-clr-cel-dis\" style=\"width:226px; text-align:left; \">\n"
"<span class=\"th-tx th-tx-value th-tx-nowrap\" style=\"width:100%; \" title=\"Social Insurance Number (SIN)\" id=\"C29_W120_V121_builidnumber_table[5].type_text\" f2=\"C;40\">\n"
" Social Insurance Number (SIN)\n"
"</span>\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.