import re
regex = re.compile(r"\A\w+_BM__[0-9]{1,6}_[0-9]{1,6}\z", flags=re.MULTILINE)
test_str = ("RP_BM_IM_17_0\n"
"BM_IM_17_0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")