// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\A\w+_BM__[0-9]{1,6}_[0-9]{1,6}\z").unwrap();
let string = "RP_BM_IM_17_0
BM_IM_17_0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}