const regex = /(?:^Caption\s*ProcessId|\G)((?:\s*)([a-zA-z\W]+.exe)\s*(\d+))/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^Caption\\s*ProcessId|\\G)((?:\\s*)([a-zA-z\\W]+.exe)\\s*(\\d+))', 'ig')
const str = `Caption ProcessId
notepad++.exe 40000
filezilla.exe 90000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}