$re = '/(?:^Caption\s*ProcessId|\G)((?:\s*)([a-zA-z\W]+.exe)\s*(\d+))/i';
$str = 'Caption ProcessId
notepad++.exe 40000
filezilla.exe 90000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);