const regex = /^[\w]+ (?!\d+\()([\w]+)\((?:(?!\d+[,\)])(\w+)),(?:(?!\d+[,\)])(\w+))\)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w]+ (?!\\d+\\()([\\w]+)\\((?:(?!\\d+[,\\)])(\\w+)),(?:(?!\\d+[,\\)])(\\w+))\\)$', 'gm')
const str = `keyword input(param_input,param_input2)
keyword 12345(param_input,param_input2)
keyword in123(abc123_DEF4,a1_b2_C3_d45)
keyword input(12345678901,param_input2)
keyword input(param_input,123456789012)
keyword input(12345678901,123456789012)
keyword XYZ98(aaaa1111BB2,CCCCCCC33333)
keyword XYZ98(aaaa1111BB2,CCCCCCC33333,DD44)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}