$re = '/^[\w]+ (?!\d+\()([\w]+)\((?:(?!\d+[,\)])(\w+)),(?:(?!\d+[,\)])(\w+))\)$/m';
$str = 'keyword input(param_input,param_input2)
keyword 12345(param_input,param_input2)
keyword in123(abc123_DEF4,a1_b2_C3_d45)
keyword input(12345678901,param_input2)
keyword input(param_input,123456789012)
keyword input(12345678901,123456789012)
keyword XYZ98(aaaa1111BB2,CCCCCCC33333)
keyword XYZ98(aaaa1111BB2,CCCCCCC33333,DD44)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);