const regex = new RegExp('[A-Z][a-z]+(?:[ -][A-Z][a-z]+)+(?= \\([A-Z]{2,}\\))|\\w+', 'gm')
const str = `Multi-Criteria Decision Making (MCDM) is increasingly used in RE projects.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}