re = /[A-Z][a-z]+(?:[ -][A-Z][a-z]+)+(?= \([A-Z]{2,}\))|\w+/m
str = 'Multi-Criteria Decision Making (MCDM) is increasingly used in RE projects.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end