import Foundation
let pattern = #"^(0[1-9]|[12][0-9]|3[01])[- \/.](0[1-9]|1[012])[-\/.]((19([6-9]\d|5[6-9]))|200[0-2])$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
11/12/1956
11/12/1955
11/12/2002
11/12/2020
10/05/1960
01/09/1957
1/9/1957
32/9/1957
31/13/1988
30/12/1999
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)