#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{4})-(ACE|AEA|A[AG]L|AN[EM]|AS[WO]|AWP|WT[EW])-(\d{3,6}.*)-(OE|NRA)$"
Local $sString = "2019-AWP-7268-OE" & @CRLF & _
"2019-AWP-659 THRU 662-NRA" & @CRLF & _
"2019-AWP-3823/3825-NRA" & @CRLF & _
"2019-AWP-4593/4594/4595/4596-NRA" & @CRLF & _
"2019-ASW-4791, 4794 THRU 4796, 4798 THRU 4800-NRA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")