use strict;
my $str = '2019-AWP-7268-OE
2019-AWP-659 THRU 662-NRA
2019-AWP-3823/3825-NRA
2019-AWP-4593/4594/4595/4596-NRA
2019-ASW-4791, 4794 THRU 4796, 4798 THRU 4800-NRA';
my $regex = qr/^(\d{4})-(ACE|AEA|A[AG]L|AN[EM]|AS[WO]|AWP|WT[EW])-(\d{3,6}.*)-(OE|NRA)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}