use strict;
my $str = '+375 (17) 111-11-11';
my $regex = qr/\D/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";