$re = '/\D/m';
$str = '+375 (17) 111-11-11';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;