$re = '/[a-z.]+|\[+|[+-]/m';
$str = 'abc[[+de.f[-[[g';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;