import re
regex = re.compile(r"[a-z.]+|\[+|[+-]", flags=re.MULTILINE)
test_str = "abc[[+de.f[-[[g"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)