import re
regex = re.compile(r"([a-z]+\:\/+)([^\/\s]+)([a-z0-9\-@\^=%&;\/~\+]*)[\?]?([^ \#\r\n]*)#?([^ \#\r\n]*)", flags=re.IGNORECASE)
test_str = ("Bob: Hey there, have you checked https://www.facebook.com ?\n"
"(ignore) https://github.com/justsml?tab=activity#top (ignore this too)\n"
"smb:///winbox/dfs/ - ipp://printer\n"
"a a:// . ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")