re = /([a-z]+\:\/+)([^\/\s]+)([a-z0-9\-@\^=%&;\/~\+]*)[\?]?([^ \#\r\n]*)#?([^ \#\r\n]*)/i
str = 'Bob: Hey there, have you checked https://www.facebook.com ?
(ignore) https://github.com/justsml?tab=activity#top (ignore this too)
smb:///winbox/dfs/ - ipp://printer
a a:// . '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end