package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[0-9]{2,7}-[0-9]{2}-[0-9]\b`)
var str = `29022-11-5
1154-12-6, 127946-96-2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}