// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[0-9]{2,7}-[0-9]{2}-[0-9]\b").unwrap();
let string = "29022-11-5
1154-12-6, 127946-96-2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}