package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\D+(\d+)\s`)
var str = `Abc 45678 cbd 00456 def 1234566`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}