$re = '/^\D+(\d+)\s/m';
$str = 'Abc 45678 cbd 00456 def 1234566';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);