re = /Release (\d+\.\d+(?:\.\d+)?)/
str = 'Release 2.6 Now Live
Release 12.46.30 Now Live
Release 2.6.0 Now Live
Release 2.6.1 Now Live'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end