import re
regex = re.compile(r"^(?:(?:https?:\/\/)?(?:(?:www|s|i2)\.)?(?:youtu\.?be|ytimg)(?:\.com)?\/)(?:watch\?v=|v\/|yt\/favicon|oembed\?|vi\/)?(?:url=http%3A\/\/www\.youtube\.com\/watch\?v%3D)?([a-zA-Z0-9_-]*).*?$", flags=re.MULTILINE)
test_str = ("https://www.youtube.com/watch?v=Gge6Hg2-RVM\n\n"
"http://www.youtube.com/watch?v=-wtIMTCHWuI\n\n"
"http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n\n"
"http://youtu.be/-wtIMTCHWuI\n\n"
"http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n\n"
"http://s.ytimg.com/yt/favicon-wtIMTCHWuI.ico\n\n"
"http://i2.ytimg.com/vi/-wtIMTCHWuI/hqdefault.jpg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")