#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:>|\s+)(?<word>@[a-zA-Z]\w+)(<|\s+)?"
Local $sString = "@word1 <p>ipsum dolor sit @word2 amet, consectetur adipiscing elit. Ut facilisis accumsan augue, <span>@word3</span>@word4 eget laoreet elit efficitur ut. sample@domain.com Fusce nulla ante, aliquam vel est sed, fringilla auctor risus. Ut consectetur mi non felis tincidunt, sit amet tincidunt massa placerat.</p>@word5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")