import Foundation
let pattern = #"(?:>|\s+)(?<word>@[a-zA-Z]\w+)(<|\s+)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"@word1 <p>ipsum dolor sit @word2 amet, consectetur adipiscing elit. Ut facilisis accumsan augue, <span>@word3</span>@word4 eget laoreet elit efficitur ut. sample@domain.com Fusce nulla ante, aliquam vel est sed, fringilla auctor risus. Ut consectetur mi non felis tincidunt, sit amet tincidunt massa placerat.</p>@word5"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)