#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([ \t]*\S.*\n)[ \t]*$\n(?=[ \t]*\S)"
Local $sString = "<nav>" & @CRLF & _
"" & @CRLF & _
" <ul>" & @CRLF & _
"" & @CRLF & _
" <li><a href="#">London</a></li>" & @CRLF & _
"" & @CRLF & _
" <li><a href="#">Paris</a></li>" & @CRLF & _
"" & @CRLF & _
" <li><a href="#">Tokyo</a></li>" & @CRLF & _
"" & @CRLF & _
" </ul>" & @CRLF & _
"" & @CRLF & _
"</nav>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"<div>new context</div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"<div>new context</div>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)