# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([ \t]*\S.*\n)[ \t]*$\n(?=[ \t]*\S)"
test_str = ("<nav>\n\n"
" <ul>\n\n"
" <li><a href=\"#\">London</a></li>\n\n"
" <li><a href=\"#\">Paris</a></li>\n\n"
" <li><a href=\"#\">Tokyo</a></li>\n\n"
" </ul>\n\n"
"</nav>\n"
" \n"
" \n"
" \n"
" \n"
"<div>new context</div>\n\n\n"
" \n"
" \n\n"
"<div>new context</div>")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.