import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<\\s*[iI][mM][gG]\\s+(.*?)src=\"(?<url>.*?)\"(.*?)\\/>";
final String string = "<h1>问题描述</h1>\n"
+ "<p>安装 VS 2019 (版本:16.0.2)后,发现更新选项中已经没有 “Entity Framework 6.X 工具” 了,打开 .edmx 文件时,呈现的视图是 xml 视图。</p>\n"
+ "<p> </p>\n"
+ "<h1>解决方案</h1>\n"
+ "<h2>1. 安装扩展</h2>\n"
+ "<p>扩展程序 <a href=\"https://marketplace.visualstudio.com/items?itemName=ErikEJ.EntityFramework6PowerToolsCommunityEdition\" target=\"_blank\">https://marketplace.visualstudio.com/items?itemName=ErikEJ.EntityFramework6PowerToolsCommunityEdition</a> </p>\n"
+ "<p> </p>\n"
+ "<h2>2. 重启 VS</h2>\n"
+ "<p> </p>\n"
+ "<h1>截图</h1>\n"
+ "<p><img src=\"https://img2018.cnblogs.com/blog/148372/201904/148372-20190429174619331-462329749.png\" alt=\"\" /></p>\n"
+ "<p> </p>\n"
+ "<p><img src=\"https://img2018.cnblogs.com/blog/148372/201904/148372-20190429174628181-393603022.png\" alt=\"\" /></p>\n"
+ "<p> </p>";
final String subst = "<a href=\"${url}\" target=\"_blank\"><img src=\"${url}\" width=\"100%\" alt=\"点击看大图\" title=\"点击看大图\" /></a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}