import re
regex = re.compile(r"\<\s*[iI][mM][gG]\s+(.*?)src=\"(?<url>.*?)\"(.*?)\/>", flags=re.MULTILINE)
test_str = ("<h1>问题描述</h1>\n"
"<p>安装 VS 2019 (版本:16.0.2)后,发现更新选项中已经没有 “Entity Framework 6.X 工具” 了,打开 .edmx 文件时,呈现的视图是 xml 视图。</p>\n"
"<p> </p>\n"
"<h1>解决方案</h1>\n"
"<h2>1. 安装扩展</h2>\n"
"<p>扩展程序 <a href=\"https://marketplace.visualstudio.com/items?itemName=ErikEJ.EntityFramework6PowerToolsCommunityEdition\" target=\"_blank\">https://marketplace.visualstudio.com/items?itemName=ErikEJ.EntityFramework6PowerToolsCommunityEdition</a> </p>\n"
"<p> </p>\n"
"<h2>2. 重启 VS</h2>\n"
"<p> </p>\n"
"<h1>截图</h1>\n"
"<p><img src=\"https://img2018.cnblogs.com/blog/148372/201904/148372-20190429174619331-462329749.png\" alt=\"\" /></p>\n"
"<p> </p>\n"
"<p><img src=\"https://img2018.cnblogs.com/blog/148372/201904/148372-20190429174628181-393603022.png\" alt=\"\" /></p>\n"
"<p> </p>")
subst = "<a href=\"${url}\" target=\"_blank\"><img src=\"${url}\" width=\"100%\" alt=\"点击看大图\" title=\"点击看大图\" /></a>"
result = regex.sub(subst, test_str)
if result:
print(result)