import re
regex = re.compile(r"(<br />)(\1{1,4})", flags=re.MULTILINE)
test_str = "<p>1<br /><br />2<br /><br /><br />3<br /><br /><br /><br />4<br /><br /><br /><br /><br />5</p>"
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)