re = /(\d{1}\.\d{5,8}|0)\s/m
str = '0.1766155 0.1658146 0.3464225 0.258326 1.040629 0.3123467 0.7877846 0.1264636 0.1854926 2.235324 0 0.3128409 0.5384811 0.2159374 0.1659985 0.2901815 0.08226276 0.1323811 0.1374549 0.04583898 0.1653796 0.02095086 0.1465107 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end