re = /(([^\.])\.{2}(?=[\s])|([^\.])\.{4,}(?=[\s]))/m
str = 'Вот.. Стоп
Так... Стоп
Блин.... Стоп'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end