# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/select\[([^\s]*(?<param>[a-z0-9]+)[^,\s]*)*\]/\1/g;t' <<< "select[ 1, 22 ,word, two words ]
attempting to load capture group with (numerics or alpha-num options) from comma separated list ignoring leading/trailing whitespace of each param but preserving space between words (ie \"two words).
results like
param1: \"1\"
param2: \"22\"
param3: \"word\"
param4: \"two words\"
once thats sorted, would liek to handle optional single quote ' around parameters.
Thanks for the consideration
"