#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "select\[([^\s]*(?<param>[a-z0-9]+)[^,\s]*)*\]"
Local $sString = "select[ 1, 22 ,word, two words ]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"attempting to load capture group with (numerics or alpha-num options) from comma separated list ignoring leading/trailing whitespace of each param but preserving space between words (ie "two words)." & @CRLF & _
"" & @CRLF & _
"results like" & @CRLF & _
"param1: "1"" & @CRLF & _
"param2: "22"" & @CRLF & _
"param3: "word"" & @CRLF & _
"param4: "two words"" & @CRLF & _
"" & @CRLF & _
"once thats sorted, would liek to handle optional single quote ' around parameters." & @CRLF & _
"" & @CRLF & _
"Thanks for the consideration" & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)