using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"begin .{1} end";
string input = @"begin é end";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}