$re = '/begin .{1} end/s';
$str = 'begin é end';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);