$re = '/PT((?P<hours>\d{0,2})H)*((?P<minutes>\d{0,2})M)*((?P<seconds>\d{0,2})S)*/m';
$str = 'PT1H';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);