// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)PT((?P<hours>\d{0,2})H)*((?P<minutes>\d{0,2})M)*((?P<seconds>\d{0,2})S)*").unwrap();
let string = "PT1H";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}