re = /^(.*\/thumb\/[0-9a-f]\/[0-9a-f]{2})\/([^\/]+\.(jpg|jpeg|png|gif))\/\d+px-(\2)/mi
str = 'https://upload.wikimedia.org/wikipedia/commons/thumb/6/6d/Royal_tyrrell_entrance.JPG/800px-Royal_tyrrell_entrance.JPG
https://upload.wikimedia.org/wikipedia/commons/6/6d/Royal_tyrrell_entrance.JPG
https://upload.wikimedia.org/wikipedia/commons/thumb/6/6d/Royal_tyrrell_entrance.jpg/800px-Royal_tyrrell_entrance.jpg
https://upload.wikimedia.org/wikipedia/commons/thumb/6/6d/Royal1000tyrrell_entrance.jpeg/800px-Royal1000tyrrell_entrance.jpeg
https://upload.wikimedia.org/wikipedia/commons/thumb/6/6d/Royal_tyrrell_entrance.png/800px-Royal_tyrrell_entrance.png
https://upload.wikimedia.org/wikipedia/commons/thumb/6/6d/Royal_tyrrell_entrance.gif/800px-Royal_tyrrell_entrance.gif
//upload.wikimedia.org/wikipedia/commons/thumb/c/cf/Flag_of_Canada.svg/30px-Flag_of_Canada.svg.png 1.5x
//upload.wikimedia.org/wikipedia/commons/thumb/8/8e/Royal_Tyrrell_Museum.JPG/220px-Royal_Tyrrell_Museum.JPG
//upload.wikimedia.org/wikipedia/commons/thumb/8/8e/Royal_Tyrrell_Museum.JPG/330px-Royal_Tyrrell_Museum.JPG 1.5x
//upload.wikimedia.org/wikipedia/commons/thumb/8/8e/Royal_Tyrrell_Museum.JPG/440px-Royal_Tyrrell_Museum.JPG 2x
//upload.wikimedia.org/wikipedia/commons/thumb/4/4a/Commons-logo.svg/18px-Commons-logo.svg.png"
//upload.wikimedia.org/wikipedia/commons/thumb/4/4a/Commons-logo.svg/27px-Commons-logo.svg.png 1.5x
//upload.wikimedia.org/wikipedia/commons/thumb/4/4a/Commons-logo.svg/36px-Commons-logo.svg.png 2x
//upload.wikimedia.org/wikipedia/commons/thumb/9/91/Joseph_Burr_Tyrrell_bust.jpg/220px-Joseph_Burr_Tyrrell_bust.jpg
//upload.wikimedia.org/wikipedia/commons/thumb/9/91/Joseph_Burr_Tyrrell_bust.jpg/330px-Joseph_Burr_Tyrrell_bust.jpg 1.5x,
//upload.wikimedia.org/wikipedia/commons/thumb/9/91/Joseph_Burr_Tyrrell_bust.jpg/440px-Joseph_Burr_Tyrrell_bust.jpg 2x
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end