const regex = /^(|by DocuSign)((|0)[1-9]|[1-2][0-9]|3[0-1])\/((|0)[1-9]|1[0-2])\/[0-9]{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(|by DocuSign)((|0)[1-9]|[1-2][0-9]|3[0-1])\\\/((|0)[1-9]|1[0-2])\\\/[0-9]{4}$', 'gm')
const str = `31/01/2021
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}