re = /^(|by DocuSign)((|0)[1-9]|[1-2][0-9]|3[0-1])\/((|0)[1-9]|1[0-2])\/[0-9]{4}$/m
str = '31/01/2021
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end