import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:\\d{1,2}\\/){2}\\d{4}\\s+(?:\\d{1,2}:){2}\\d{1,2}).*";
final String string = "5/25/2022 14:13:05\n"
+ "5/25/2022 13:21:07 EDT\n"
+ "5/25/2022 17:07:39 GMT+01:00";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}