re = /^((?:\d{1,2}\/){2}\d{4}\s+(?:\d{1,2}:){2}\d{1,2}).*/m
str = '5/25/2022 14:13:05
5/25/2022 13:21:07 EDT
5/25/2022 17:07:39 GMT+01:00'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result